Frequently Asked Questions

General Questions

Can I help with OpenLP?

OpenLP is possible because of the commitment of individuals. If you would like to help there are several things that you can get involved with. Please see: Contributing for more information.

I use and like OpenLP and would like to tell others online. Where can I do this?

A variety of places!

  • Are you on facebook? Then become a fan
  • Are you on twitter? Then follow openlp, and retweet the announcements.
  • Give us a thumbs up on the SourceForge project page
  • If you have a website or blog, then link to our site http://www.openlp.org with a few words saying what the software is and why you like it.
  • Add a placemark on our Worldwide Usage map, so others in your locality can see someone close by is using it.
  • If you are a member of any Christian Forums or websites, and their rules allow it, then perhaps review the software or ask others to review it.

What operating systems will OpenLP 2.0 support?

OpenLP 2.0 is designed to be cross platform. Currently it has been known to run on Windows (XP, Vista, 7), Linux (Ubuntu/Kubuntu, Fedora), FreeBSD & Mac OSX. Please let us know if you’ve successfully run it on something else.

Which programming language is 2.0 developed in?

OpenLP 2.0 is written in Python and uses the Qt4 toolkit. Both are cross-platform which allows the software to run on different types of machine and so allow more people access to free worship software. Python is one of the easier programming languages to learn, so this helps us develop and find bugs quicker, and also allows more developers to contribute with the project.

Which written languages does OpenLP support?

OpenLP has support for multiple languages which can be seen on the Settings ‣Translate menu. However some of these translations are incomplete. If you would like to help complete or start to translate OpenLP into your language then see the Getting started page.

What is a beta release?

A beta release is a release which is almost feature complete and is fairly stable. However there may still be a few features to complete, and bugs we’ve not yet fixed. It is used by several people without serious problems. However there is a small possibility that it could still crash occasionally or do unexpected things. It is intended for those who want the latest version, and are prepared to give the program a good test before using it in a live situation to ensure they won’t encounter any unexpected problems. If you want to have a look at the latest beta release then just download it.

Upgrading

Does 2.0 replace 1.2, or can they be run side by side?

It is perfectly safe to install 2.0 on a system with 1.2. Both versions are installed in separate places, so you can still go back to 1.2. You can even run them at the same time!

2.0 stores its data in a separate folder to 1.2, so your data is perfectly safe, and whatever you do in 2.0 will not damage 1.2

Are 1.2 and 2.0 compatible?

No. However imports exist to transfer your data to the new version.

I have a computer that is quite old, should I upgrade?

2.0 does require significantly more resources than v1.2. Therefore if your computer does not have much memory you may find 2.0 will struggle, especially when changing between slides.

Why can I not see my 1.2 songs, bibles and themes in 2.0?

This is an beta release, which means it is not finished and one of the things we haven’t completely finished yet is importing 1.2 data automatically. We plan to do this Version 1.9.6 (beta 2).

How do I transfer my 1.2 song database?

In OpenLP 2.0, go to the File ‣ Import ‣ Song menu. In the Wizard that appears, click Next and choose “openlp.org v1.x” from the Format list. Click the search button on the Filename prompt, and at the bottom of the dialog, copy the following into the File name prompt:

%ALLUSERSPROFILE%\Application Data\openlp.org\Data\songs.olp

(This must be in the popup file chooser dialog. Don’t enter it directly into the wizard).

Click Open, then in the wizard just click Next and wait for the import to complete.

How do I transfer my 1.2 Bibles?

In OpenLP 2.0, go to the File ‣ Import ‣ Bible menu. In the Wizard that appears, click Next and choose “openlp.org v1.x” from the Format list. Click the search button on the Filename prompt, and at the bottom of the dialog, copy the following into the File name prompt:

%ALLUSERSPROFILE%\Application Data\openlp.org\Data\Bibles

(This must be in the popup file chooser dialog. Don’t enter it directly into the wizard).

Choose the Bible, Click Open, then in the wizard just click Next, enter the License details, and wait for the import to complete.

How do I transfer my 1.2 Themes?

In openlp.org v1, export each theme by selecting it in the Theme Manager, and then clicking the picture of a blue folder with red arrow on the Theme Managers toolbox. This theme file can then be imported into V2 using the File ‣ Import ‣ Theme menu.

I can’t get my 2.0 theme to look the same as 1.2

OpenLP 2.0 is a complete rewrite using a completely different programming language so it would work on different types of system. There are differences in how the old and new languages draw text on the screen, and therefore it is unlikely you’ll get an exact match.

Using OpenLP

I’ve started OpenLP, but I can’t see the songs or bibles section in the Media Manager

When you installed OpenLP, the first time wizard would have asked which plugins you wanted, and songs and bibles should have been selected. If for some reason they were not, then you will need to activate them yourself. See How do I activate / deactivate a plugin for instructions.

How do I activate / deactivate a plugin?

Plugins can be turned on and off from the Plugin List Screen. Select the plugin you wish to start/stop and change it’s status. You should not need to restart OpenLP.

What are these plugins that I keep seeing mentioned?

The plugins allow OpenLP to be extend easily. A number have been written (Songs, Bibles, Presentations) etc but it is possible for the application to be extended with functionality only you require. If this is the case then go for it but lets us know as we can help and it may be something someone else wants.

How do I enable PowerPoint/Impress/PowerPoint Viewer?

First of all ensure that the presentation plugin is enabled (see above). Then to enable a presentation application, go to the Settings dialog, switch to the Presentations tab and check one of the enabled checkboxes. OpenLP will automatically detect which of the three you have installed, and enable the appropriate checkbox(es). Check the applications you require, and then restart OpenLP for the change to be detected. Note, PowerPoint Viewer 2010 is not yet supported, use 2003 or 2007.

See also I’m on Windows and PowerPoint is installed, but it doesn’t appear as an option and Why is there no presentations plugin available on OS X?

Why is there no presentations plugin available on OS X?

Currently the presentations plugin is not bundled with OpenLP on OS X. The reason for that is that the OpenOffice.org version on Mac OS X does not contain the (more exact: does only contain a broken) interoperability component (the so called pyuno bridge) which could be used by OpenLP. As soon as the interoperability component works on OS X we can re-enable the plugin and bundle it. We are really sorry for that.

Is it possible to get Bible x? How?

The Bible plugin has a much improved Import Wizard which can import Bibles from a variety of sources. The following sources are supported:

CSV
The same format as documented for openlp.org 1.x.
OSIS

An XML format for Bible. You can export Bibles from the Sword Project into OSIS using the mod2osis tool. After using the Sword software Media Manager (or other Sword frontend, like BibleTime or Xiphos) to download the required Bible, run the following command from the command line (works on Windows and Linux):

mod2osis <name> > <name>.osis

The <name> parameter is the name of your Bible, as you see it in Sword. Note that the <name> is case sensitive on all environments. Once you have exported your Bible to OSIS, the Bible import wizard will the read <name>.osis file and import your Bible.

OpenSong
OpenSong has a good selection of Bibles on their download page.
Web Download

OpenLP can download Bibles on demand from the following 3 sites:

Why do my Bible verses take a long time to load?

In order to better conform to copyright law, the Web Download Bibles are not downloaded when you import them, but on the fly as you search for them. As a result, the search takes a little longer if you need to download those particular verses. Having said that, the Web Download Bibles cache downloaded verses so that you don’t need to download them again.

My Bible is on the Web Download sites, but my Church isn’t on the internet. What options do I have?

When you create and save a service, all the items in the service are saved with it. That means any images, presentations, songs and media items are saved. This is also true for bibles. What this means is you can create the service on your home computer, insert a Bible passage from the web, save it and then open the service using your church computer and voila, the Bible passage should be there! Note this can also be done with songs, etc!

(Advanced) Where do I find the configuration file?

Linux, FreeBSD & PC-BSD

If your distribution supports the XDG standard, you’ll find OpenLP’s configuration file in:

/home/<user>/.config/OpenLP/OpenLP.conf

If that file and/or directory does not exist, look for:

/home/<user>/.openlp/openlp.conf

<user> is your username.

OS X

You’ll find your configuration file here:

/Users/<user>/Library/Preferences/org.openlp.OpenLP.plist

<user> is your username.

Windows

On Windows, OpenLP does not use a configuration file, it uses the Windows registry. You can find the settings here:

HKEY_CURRENT_USER\Software\OpenLP\OpenLP

Troubleshooting

Something has gone wrong, what should I do to help get it fixed?

If you have found an error in the program (what we call a bug) you should report this to us so that OpenLP can be improved. Before reporting any bugs please first make sure that there isn’t already a bug report about your problem:

  1. Check the Launchpad bug list
  2. OpenLP support System
  3. Check the bug reports forum

If there is already a bug report, you may be able to help by providing further information. However, if no one else has reported it yet, then please post a new bug report.

  1. The preferred place for reporting bugs is the bugs list on Launchpad.
  2. Alternatively, if you don’t have a Launchpad account and don’t want to sign up for one, you can post in the bug reports forum.
  3. If none of these ways suits you, you can send an email to bugs (at) openlp.org.

What information should I include in a bug report?

Since OpenLP 1.9.4, there is a bug report dialog which automatically opens when OpenLP hits a serious bug. However, this doesn’t appear all the time, and in some behavioural bugs, you’ll have to file a bug report yourself. The following items are information the developers need in order to reproduce the bug.

Operating System
Include information such as the version of your operating system, the distribution (e.g. Ubuntu, Fedora, etc.) if you’re using Linux, or the edition (e.g. Home, Basic, Business, etc.) if you’re using Windows.
Version of OpenLP
You can find out the version of OpenLP by going to Help ‣ About
Steps to Reproduce
The exact steps the developers need to follow in order to reproduce the bug.
Version of MS Office or OpenOffice
If you’re using the song imports or the presentation plugin, you’ll need to supply the version of Office, OpenOffice.org or LibreOffice.
Bible Translation and Source
If the bug occurred while you were working with Bibles, specify the translation of the Bible, and the source format if you imported it yourself.
Any Other Information
Often bugs are caused by something that might not seem to be directly related to the bug itself. If you have any other information with regards to actions you performed or other activities when the bug occurred, it would be welcomed by the developers.

The more information you give us, the better we can help you.

I’ve been asked to email a debug log, where do I find this?

We may need a debug log to help pin-point the issue. A new log file is created each time you start OpenLP so copy the file before you run the software a second time. On Windows a Debug option is available in the start menu. On other systems, you will need to run OpenLP from the command line, with the following option: `-l debug`. Please note, that is a lowercase L.

If you haven’t been given a specific email address to send it to, then please do not paste the log contents straight into a forum post. Instead, open the log file in a text editor (such as notepad on Windows) and copy and paste the contents into somewhere like pastebin.com. Then give us the link to the page that is created.

Windows

Find the OpenLP 2.0 folder in your Start menu. Choose the “OpenLP (Debug)” option.

OpenLP will start up. Go to the Tools ‣ Open Data Folder menu option, and an Explorer window will appear containing folders such as alerts, bibles, custom etc. Keep this Explorer window open.

Now repeat the steps you need to take in OpenLP to reproduce the problem you had, and then close down OpenLP.

In the Explorer window you left open, navigate up one level into the openlp folder. You will see the openlp.log file. This is the file to e-mail.

Linux/FreeBSD

If you installed OpenLP from a package:

@:~$ openlp -l debug

Alternately, if you’re running OpenLP from source:

@:~$ ./openlp.pyw -l debug

If your Linux distribution supports the XDG standard, you’ll find the log in:

~/.cache/openlp/openlp.log

Otherwise, you’ll find the log file in:

~/.openlp/openlp.log

Mac OS X

Open Terminal.app and navigate to where you installed OpenLP, usually /Applications:

@:~$ cd /Applications

Then go into the OpenLP.app directory, down to the OpenLP executable:

@:~$ cd OpenLP.app/Contents/MacOS

And then run OpenLP in debug mode:

@:~$ ./openlp -l debug

Once you’ve done that, you need to get the log file. In your home directory, open the Library directory, and the Application Support directory within that. Then open the openlp directory, and you should find the openlp.log file in that directory:

/Users/<username>/Library/Application Support/openlp/openlp.log

<username> is your username.

I’m on Windows and PowerPoint is installed, but it doesn’t appear as an option

Try installing the Visual C++ Runtime Redistributable.

The command line shows many error messages

When running OpenLP from the command line, you might get something like this:

WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  VideoDisplay ( no objectName ).
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded

These error messages indicate that you need to install an appropriate backend for Phonon.

Linux/FreeBSD

If you’re using Gnome, you need to install the GStreamer backend for Phonon. On Ubuntu you would install the `phonon-backend-gstreamer` package:

@:~$ sudo aptitude install phonon-backend-gstreamer

If you’re using KDE, you need to install the Xine backend for Phonon. On Kubuntu you would install the `phonon-backend-xine` package:

@:~$ sudo aptitude install phonon-backend-xine

If you know which audiovisual system you’re using, then install the appropriate backend.

phonon-backend-vlc may also be worth trying on some systems.

Windows & Mac OS X

Phonon should already be set up properly. If you’re still having issues, let the developers know.

I’ve upgraded from 1.9.2 to a newer version, and now OpenLP crashes on load

You need to upgrade your song database. See this blog post for information on how to do this.

I’ve upgraded to 1.9.5, and now OpenLP has duplicates of many songs in the Media Manager

You need to run Tools ‣ Re-index Songs.

There are no menu icons in OpenLP

This may affect (only) Linux users with XFCE or Gnome. To solve the problem, follow the instructions on this bug report.

JPEG images don’t work

This is a known issue on some Mac OS X 10.5 systems, and has also been seen on Windows XP too. The solution is to convert the image into another format such as PNG.

MP3’s and other audio formats don’t work

This is a known issue on some systems, including some XP machines, and we have no solution at the moment.

Videos can be slow or pixelated. Background Videos are very slow

If you are just playing videos from the Media plugin, try selecting the Use Phonon for Video playback option in the Media configuration, accessible by going to Settings ‣ Configure OpenLP ‣ Media. As for text over video, we have no solution for speeding this up. Reducing the monitor resolution and avoiding shadows and outline text will help. We are hoping a future release of the toolkit we are using (QtWebKit) will help improve this, but there is no timeframe at present.

Features

What new features will I find in 2.0?

Since 2.0 was a rewrite from the ground up, you won’t find a great deal of new features since initially we want to ensure all the 1.2 features are included. However the developers have managed to sneak a few in. Take a look at the complete list.

I have a great idea for a new feature, where should I suggest it?

First of all check it isn’t on the Feature Requests page. If it is, then you need to say no more, it’s already been suggested! If it isn’t on the list, then head to the feature request forum and post the idea there.

Table Of Contents

Previous topic

Glossary

Next topic

Troubleshooting

This Page